Since version 0.14 we are getting error when deploying our app on AWS:
> adapterjs@0.14.0 postinstall /tmp/deployment/application/node_modules/adapterjs
> npm --prefix third_party/adapter install third_party/adapter
npm ERR! Linux 4.4.14-24.50.amzn1.x86_64
npm ERR! argv "/opt/elasticbeanstalk/node-install/node-v4.4.6-linux-x64/bin/node" "/opt/elasticbeanstalk/node-install/node-v4.4.6-linux-x64/bin/npm" "--prefix" "third_party/adapter" "i
nstall" "third_party/adapter"
npm ERR! node v4.4.6
npm ERR! npm v2.15.5
npm ERR! path /tmp/.npm/sdp
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall mkdir
npm ERR! Error: EACCES: permission denied, mkdir '/tmp/.npm/sdp'
npm ERR! at Error (native)
npm ERR! { [Error: EACCES: permission denied, mkdir '/tmp/.npm/sdp']
npm ERR! errno: -13,
npm ERR! code: 'EACCES',
npm ERR! syscall: 'mkdir',
npm ERR! path: '/tmp/.npm/sdp',
npm ERR! parent: 'webrtc-adapter' }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.
npm ERR! Please include the following file with any support request:
npm ERR! /tmp/deployment/application/node_modules/adapterjs/npm-debug.log
npm WARN deprecated cross-spawn-async@2.2.4: cross-spawn no longer requires a build toolchain, use it instead!
Problem has been probably caused by caf91bd.
Workaround is to execute following commands on the AWS EB server before deploying:
chmod a+rwx /tmp/.npm
chmod a+rwx /tmp/.npm/_locks
Is it a bug in AWS or could it be fixed in AdapterJS?
Since version 0.14 we are getting error when deploying our app on AWS:
Problem has been probably caused by caf91bd.
Workaround is to execute following commands on the AWS EB server before deploying:
Is it a bug in AWS or could it be fixed in AdapterJS?